[flutter]Execution failed for task ':shared_preferences:verifyReleaseResources'.


現象


flutterでGoogle Payで公開用のapkを作ろうとして、flutter build apk をすると上記エラーが発生してビルドできない。



原因


build.gradleのcompileSdkVersionが28以上でないとダメらしい。

これは色々なページに書いてあるので早速

android/app/build.gradle

を変更。しかしエラーは解消されない。


実はサードパーティ製のライブラリを導入している場合、各ライブラリ毎にbuild.gradleが存在するので、それらのcompileSdkVersionがすべて28以上でないといけない。

僕の場合は上記のようにshared_preferencesでエラーが出ているので、

External Libraries/Flutter Plugins/

のshared_preferencesのbuild.gradleを見てみると、確かにcompileSdkVersionが27だった。


公式サイトで調べると、僕がインストールしていたのはバージョンが古かった模様。pubsec.yamlを編集して最新版に更新すると、無事ビルドできた。



最後に


pub getする場合はちゃんと最新版を入れましょう。特にwebページからコピペする場合は版数が古かったりするので注意!

最新記事

すべて表示

現象 flutter_local_notificationを使って通知を作成。通知タップ時の動作も登録。 通知が来た時にアプリが立ち上がっている(foregroundでもbackgroundでも)と、期待通りの動作となる。 しかし、通知が来た時にアプリが終了していると、通知をタップしても登録した動作とならない。 原因と解決策 アプリが終了すると登録した動作は消えてしまうらしい(参考)。 Note:

概要 Firebase Messagingでメッセージを送信し、通知がタップされたら何らかの動作を実行する(例:特定のページに移動する)という場合は多いかと思います。 通知タップ時にアプリがforeground状態(つまりアプリを開いている)ならば簡単なのですが、アプリがbackground状態にある場合は少し工夫が必要です。 方法 FirebaseMessaging.onBackgroundMe

現象 FirebaseMessaging.onBackgroundMessage()でタイトルのエラーが発生。 原因と解決策 上記メソッドの引数に渡すデリゲートはトップレベル関数でなければならない。自分の場合はインスタンスメソッドを渡していたのでエラーとなった。 渡すメソッドをトップレベル関数にするとエラーは解消した。 @main.dart void main() async{ //略 F

靴を大切にしよう!靴管理アプリ SHOES_KEEP

納品:iPhone6.5①.png

靴の履いた回数、お手入れ回数を管理するアプリです。

google-play-badge.png
Download_on_the_App_Store_Badge_JP_RGB_blk_100317.png

テーマ日記:テーマを決めてジャンルごとに記録

訂正①2040×1152.jpg

ジャンルごとにテーマ、サブテーマをつけて投稿、記録できる日記アプリです。

google-play-badge.png